Testing, testing

January 23, 2005 at 5:34 pm | In yulelogStories | 5 Comments

I want to post a Flickr link in my sidebar (mostly because I’m thinking of upgrading to Pro so I can start to post lots and lots of pictures there), but when I try to do so, the html code gets messed up. The pointy brackets at the beginning of the script get turned into ampersand, l, t, and semi-colon. This also happens when I try to copy and paste what I write (in TextEdit) using the Firefox or Opera or Safari browser. Weirdly, I can only post something using an ancient version of Internet Explorer. When I tried, just now, to add the Flickr link code to the ‘About’ sidebar, however, even IE wouldn’t do it. Hence, a test to see whether the code will work in a regular post:

Nope, doesn’t work. You cannot see the lovely Flickr link, can you? You see a pointy bracket at the beginning of the code, but what I see in the posting window is this:

& l t ; script type=”text/javascript”> (albeit without the spaces inbetween the ampersand, the l, the t, and the semi-colon: I had to put those in, otherwise it shows up as a pointy bracket — without making the desired link, though.

The closing pointy bracket stayed ok, but the opening pointy bracket got changed (why??) to & l t ; . If I type that sequence without spaces, it will show up as a pointy bracket [______________________________________________
Re. the long lag in posting anything here: been sick. Really really sick, something to share with the rest of the family, too. Better now; they, too. Spent much time reading, as well as writing annoying letters to the BC Minister of Agriculture; the local paper (in their online “sound off section” — actually, that was a short note); a biographical paragraph for an upcoming election (that was interesting: I learned something about myself); and several seemingly endless harangues to various educational personages concerning technology usage.

My first sculpture model in decades sits unfinished in another room. My camera wants me to take it places, to document our supposed booming growth in the Capitol Regional District — as well as a stunning (finally) piece of setting sun (sun, we actually saw the sun today!) over the Juan de Fuca Strait, with the Olympic Mountain range in the background, and my head is full of readings on biogenetics and biomimicry (William Leiss’s & Michael Tyshenko’s “Life in the Fast Lane: An Introduction to Genomics Risks” and Janine Benyus’s book, Biomimicry), but let’s not forget what’s really important in a life like this: getting the laundry done. That’s my life: between the sheets, or washing ’em. Sigh.

5 Comments

  1. Why do you have the first part of your script commented out? The part between <!-- and //-->

    Comment by Doug Alder — January 23, 2005 #

  2. I’m not sure why it’s like that. That script is something I copied (& pasted) directly from the Flickr site: it’s on this page, “How to make a Flickr badge”. What concerns me is that when I use Firefox et al., I can’t even do simple things like italics or bold or ANYTHING that involves the pointy bracket at the beginning. It all gets turned into gobble-de-gook, with the pointy bracket turned into ampersand, l, t, semicolon.

    Watch, I’ll try something: I’ll type the preceding sequence with spaces, and then the same sequence without spaces. Let’s see if the latter turns into a pointy bracket [<]:

    & l t ;

    <

    Comment by Yule Heibel — January 24, 2005 #

  3. See, it turns into a pointy bracket. Now imagine the reverse occuring, without anything I seem to be able to do about it: any html that I write as a pointy-bracket-followed-by-something, whether ‘a href’ or ‘i’ or ‘b’ or whatever, gets turned into that sequence of & l t ;, and there’s nothing I can do about it! It drives me nuts, and I’ve been working around it for months and months by using this old IE version. But when I tried posting something in the sidebar, even in IE, the html got screwed up, and now I’m worried that eventually this problem will creep right into posting my entries with IE. EEk!

    Comment by Yule Heibel — January 24, 2005 #

  4. I said EEK! too, but it was bookended by GEEK alert! lol. I wish you luck. I’m still trying to figure out my blogroll n’stuff.

    I hope you are feeling better, Yule. Everybody seems to have gotten some kind of crud this season. I guess it’s been too cold here so far, for any bugs to live … other than the ones hiding deep, deep inside my computer. I would need plutonium to burn those suckers out.

    Comment by Kate S. — January 24, 2005 #

  5. Thanks, Kate. This isn’t my bag, either, but aside from the obvious (that there is/was something wonky about the Flickr script I copied and pasted from the flickr site), the actual problem (that identical text gets rendered correctly in one browser, but not in another, and that even putting the text in Emacs doesn’t fix it) is still an odd mystery. Maybe it’s not a common problem because most people compose directly in their little blog browser window. But I don’t. I actually write these things out in advance somewhere else (TextEdit, eg.), with all the tags for links and italics and indents and so forth as HTML in my text, after which I then copy & paste the whole thing into the blogger window.

    Comment by Yule Heibel — January 27, 2005 #

Sorry, the comment form is closed at this time.

Theme: Pool by Borja Fernandez.
Entries and comments feeds.